0

Konfiguracja routingu statycznego – Cisco IOS

Konfiguracja routingu statycznego dokonana została na topologii zaprezentowanej poniżej.

konfiguracja routingu statycznego

Krok 1 – konfiguracja interfejsów

W pierwszym etapie musimy skonfigurować adresy IP na każdym interfejsie routerów. W tym celu uzyskujemy dostęp do routera R1. Przechodzimy do trybu uprzywilejowanego poleceniem enable, a następnie do trybu konfiguracji globalnej poleceniem configure terminal. Dalej udajemy się do konfiguracji interfejsu stosując komendę interface nazwa-interfejsu, przykładowo interface GigabitEthernet0/0. Oraz ustawiamy adres IP interfejsu poleceniem ip address adres maska, przykładowo ip address 10.1.1.1 255.255.255.252. Na koniec podnosimy interfejs poleceniem no shutdown. W przypadku kiedy jest to połączenie router-router, aby zapaliła się zielona lampka musimy skonfigurować adresy IP po obydwu stronach łącza. Czynność powtarzamy dla każdego interfejsu oraz na każdym routerze. Kompletna kopia komend zastosowanych na routerze R1 została zaprezentowana poniżej.

R1>enable

R1#configure terminal

R1(config)#interface GigabitEthernet0/0

R1(config-if)#ip address 10.1.1.5 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#interface GigabitEthernet0/1

R1(config-if)#ip address 10.1.1.21 255.255.255.252

R1(config-if)#no shutdown

R1(config-if)#interface GigabitEthernet0/2

R1(config-if)#ip address 10.1.1.1 255.255.255.252

R1(config-if)#no shutdown

Po pomyślnej konfiguracji interfejsów routerów, przechodzimy do urządzeń końcowych by także przypisać im adresy IP. Klikając na ikonę komputera przechodzimy do zakładki Desktop i wybieramy IP Configuration. Statycznie ustawiamy odpowiedni adres IP, maskę podsieci oraz bramą domyślną. Jako brama domyślna będzie to adres IP routera znajdującego się w tej samej podsieci. Na tym etapie nie możemy wysłać wiadomości z jednej sieci lokalnej do drugiej. Przykładowo pingowanie PC2 przez PC1 zakończy się niepowodzeniem. Powodem jest brak wiedzy przez routery o sieciach zdalnych. W związku z czym zabierzemy się teraz za konfigurację routingu statycznego, aby routery miały kompletną informację o topologii sieci.

Krok 2 – konfiguracja routingu statycznego

Konfiguracja routingu statycznego będzie polegała na ręcznym wpisie zdalnych sieci. Należy przejść do trybu konfiguracji globalnej, a następnie zastosować polecenie:

ip route <adres-podsieci> <maska podsieci> <interfejs-wychodzący>

Dla routera R1 będzie to wyglądało następująco:

R1(config)#ip route 10.1.1.8 255.255.255.252 GigabitEthernet0/0

R1(config)#ip route 10.1.1.12 255.255.255.252 GigabitEthernet0/0

R1(config)#ip route 10.1.1.16 255.255.255.252 GigabitEthernet0/1

Jeżeli podczas konfiguracji popełnimy błąd, to wpis możemy usunąć poleceniem:

no ip route <adres-podsieci> <maska podsieci> <interfejs-wychodzący>

dla przykładu, chcąc usunąć trasę 10.1.1.16/30 wykonamy następujące polecenie:

no ip route 10.1.1.16 255.255.255.252 GigabitEthernet0/1

Poprawność konfiguracji sprawdzimy poprzez wysłanie wiadomości ping z urządzenia PC2 do PC1. Jak widać na poniższym obrazku komputery poprawnie się komunikują. Zwykle po konfiguracji pierwszy pakiet jest utracony, co możemy zauważyć (25% loss).

W trybie użytkownika uprzywilejowanego możemy także zobaczyć tablicę routingu wydając polecenie show ip route. Wynik powinien być zbliżony do poniższego.

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks

C 10.1.1.0/30 is directly connected, GigabitEthernet0/2

L 10.1.1.1/32 is directly connected, GigabitEthernet0/2

C 10.1.1.4/30 is directly connected, GigabitEthernet0/0

L 10.1.1.5/32 is directly connected, GigabitEthernet0/0

S 10.1.1.8/30 is directly connected, GigabitEthernet0/0

S 10.1.1.12/30 is directly connected, GigabitEthernet0/0

S 10.1.1.16/30 is directly connected, GigabitEthernet0/1

C 10.1.1.20/30 is directly connected, GigabitEthernet0/1

L 10.1.1.21/32 is directly connected, GigabitEthernet0/1

Górna część “Gateway of last resort is not set” oznacza że brama ostatniej szansy nie została skonfigurowana. Jest to wpis w tablicy routingu 0.0.0.0, który pozwala routerowi przekierować pakiet na ustawiony interfejs jeżeli nie dopasował on dla niego odpowiedniego wpisu.

NetFreak

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *